World Families Forums - What happened to the U5 Forum?

ARCHIVAL COPY
Home Help Search Login Register
This is an archival copy of the old forum. This copy does not allow new posts, nor can you log in to this forum.
For the current active forum, please visit https://www.worldfamilies.net/forum.

+  World Families Forums
|-+  Special Forums - Note: You must be Logged In to Post. Anyone can browse.
| |-+  Notify us of a Problem
| | |-+  What happened to the U5 Forum?
« previous next »
Pages: [1] Go Down Print
Author Topic: What happened to the U5 Forum?  (Read 3825 times)
PDHOTLEN
Member
**
Offline Offline

Posts: 19


« on: October 11, 2007, 12:59:16 AM »

I haven't been able to connect with the U5 Forum for quite some time now. Is it off the air permanently? Or does it have a new URL? I had it bookmaked, but now the bookmark no longer works. I am using a MAC.
« Last Edit: October 11, 2007, 01:00:11 AM by PDHOTLEN » Logged

U5b2/U5b2b2 (traces to colonial USA European) & R1a1a1 L664+ (Norwegian descent); X chromosome (not tested) = half Austrian and half Colonial USA. FTDNA kit #54319. Genebank EF419891. MitoSearch/Y-Search #G986T.

Terry Barton
Administrator
Guru
*****
Offline Offline

Posts: 1679


« Reply #1 on: February 01, 2009, 01:11:48 PM »

The U5 Forum is at:

http://www.worldfamilies.net/forum/index.php?board=1493.0
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


SEO light theme by © Mustang forums. Powered by SMF 1.1.13 | SMF © 2006-2011, Simple Machines LLC

Page created in 0.157 seconds with 17 queries.